4.0 

Installing The Killer 1535/1525/1435 in Ubuntu/Debian

Ubuntu/Debian 14.04

You will first need to install the latest backports package to have up to date drivers. 

https://help.ubuntu.com/community/UbuntuBackports#Installing_Backports

Ubuntu/Debian 16.04

The built in drivers should work without any changes, though you may need to update your wireless firmware:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.169.3_all.deb
sudo dpkg -i linux-firmware*.deb
sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

The 1535 1525 and 1435 use the community developed and supported ath10k driver. Killer Networking neither develops nor supports the ath10k driver. For further support, please refer either to the community support for you specific Linux distrobution and version, or the driver itself. 

Have a question about your Killer product that isn't answered in our Knowledge Base?  Contact Us.