Linux

Linux Support

4.5 

Linux Support

Most Killer Networking adapters work well with most Linux kernels without the need for any troubleshooting or setup. As there are many Linux distributions, and many variations of those distributions, some users may run into issues with compatibility and their networking adapter.

These are the drivers used by our networking adapters:

With the exception Killer Wireless-AC 1550 series, the drivers for all of our devices are community developed and supported. We neither develop nor support the Linux drivers for our devices, and this is common, as free and open source is the Linux way.

As such, if you encounter an issue with your Killer Networking adapter in Linux, your best, quickest, and most accurate line of support is going to be the community, either for the Linux distribution that you are using, or the driver itself. Our knowledge base contains some limited known information. These are things which we have discovered and posted in order to hopefully make things easier on our users. However, most problems will be specific to either the driver, the distribution, or even the version of the distribution that you are using.

Following are some links to installation tips for specific Linux distributions, which were offered by our users. Please note that, unless you see this note beside the link - Confirmed By Killer Support - these are links to various places in the community where others have offered up solutions to problems, which have been confirmed by other users. 

Linux Mint

Killer Wireless-AC 1550 install in Linux Mint - https://forums.linuxmint.com/viewtopic.php?f=53&t=272888 (Thanks JeremyB!)

The Killer 1535/1525/1435 in Ubuntu/Debian

4.0 

Installing The Killer 1535/1525/1435 in Ubuntu/Debian

Ubuntu/Debian 14.04

You will first need to install the latest backports package to have up to date drivers. 

https://help.ubuntu.com/community/UbuntuBackports#Installing_Backports

Ubuntu/Debian 16.04

The built in drivers should work without any changes, though you may need to update your wireless firmware:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.169.3_all.deb
sudo dpkg -i linux-firmware*.deb
sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

The 1535 1525 and 1435 use the community developed and supported ath10k driver. Killer Networking neither develops nor supports the ath10k driver. For further support, please refer either to the community support for you specific Linux distrobution and version, or the driver itself. 

Wi-Fi Issues with 1435/1535/1525 on Debian, Ubuntu, and Arch

2.3 

Wi-Fi Disconnects and Latency with 1435/1535/1525 on Debian, Ubuntu, and Arch

Some users have noted Wi-Fi disconnects and latency on some distros of Linux after recent updates.

This issue likely affects Debian, Ubuntu, and Arch, and may also affect any other Debian-based distros such as Mint, Kali, etc. 

As the ath10k Wi-Fi driver that is used by our Wi-Fi devices in these versions of Linux is a community sourced driver, we have no direct impact on its stability, but since some users have indicated that they have found a fix for these issues, we wanted to share the fix with the rest of our users. 

In summary, the fix is to install the updated firmware and firmware repo, following these steps:

  1. Download https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board-2.bin and overwrite /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin with the downloaded file.
  2. Download https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/4.4.1/firmware-6.bin_WLAN.RM.4.4.1-00065-QCARMSWP-1and overwrite /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin.
  3. Restart

Following is a much more detailed, step-by-step guide on how to implement this fix:

  1. Open a Terminal window and navigate to the following location:
    cd /lib/firmware/ath10k/QCA6174/hw3.0/
  2. Backup your board-2.bin and firmware-6.bin files:
    sudo mv /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin.bak
    sudo mv /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin /lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin.bak
  3. Download the two replacement versions and place them into the '/lib/firmware/ath10k/QCA6174/hw3.0/' folder:
    Download: https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board-2.bin
    Download: https://github.com/kvalo/ath10k-firmware/raw/master/QCA6174/hw3.0/4.4.1/firmware-6.bin_WLAN.RM.4.4.1-00065-QCARMSWP-1
  4. Rename your new 'firmware-6...' file to 'firmware-6.bin':
    sudo mv firmware-6.bin_WLAN.RM.4.4.1-00065-QCARMSWP-1 firmware-6.bin
  5. Enter ls -la into your terminal to verify the directory looks something like this:
    user@Ubuntu-XPS:/lib/firmware/ath10k/QCA6174/hw3.0$ ls -la
    total 3168
    drwxr-xr-x 2 root root 4096 Feb 6 15:29 .
    drwxr-xr-x 4 root root 4096 Jun 24 2016 ..
    -rw-r--r-- 1 root root 271412 Feb 6 15:30 board-2.bin
    -rw-r--r-- 1 root root 271412 Feb 6 15:28 board-2.bin.bak
    -rw-r--r-- 1 root root 337204 Nov 15 15:56 board-2.bin.wifi-qca6174
    -rw-r--r-- 1 root root 8124 May 12 2016 board.bin
    -rw-r--r-- 1 root root 8124 Dec 1 2016 board.bin.wifi-qca6174
    -rw-r--r-- 1 root root 733784 Dec 1 2016 firmware-4.bin
    -rw-r--r-- 1 root root 711408 Feb 6 15:30 firmware-6.bin
    -rw-r--r-- 1 root root 711408 Feb 6 15:28 firmware-6.bin.bak
    -rw-r--r-- 1 root root 79689 Dec 1 2016 notice_ath10k_firmware-4.txt
    -rw-r--r-- 1 root root 82663 Nov 15 15:44 notice_ath10k_firmware-6.txt
  6. Restart your computer.

The 1535 1525 and 1435 use the community developed and supported ath10k driver. Killer Networking neither develops nor supports the ath10k driver. For further support, please refer either to the community support for you specific Linux distrobution and version, or the driver itself.

Killer 1550 in Linux Debian/Ubuntu 16.04+

 

Killer 1550 in Debian/Ubuntu 16.04+

Some users have expressed a desire to use the Killer 1550 in Debian-based Linux. If your version of Linux does not support the Killer Wireless-1550 at install, and you are using Ubuntu 16.04 or later, or another version of Debian Linux, you can use this guide to backport the drivers from the latest version of Ubuntu/Debian, enabling the Killer 1550 in 16.04 or later. We have confirmed that this will result in wireless connectivity in Ubuntu 16.04 with the Killer Wireless-AC 1550. 

Please note that Secure Boot must be disabled in your BIOS before following these steps. If you are unsure how to disable Secure Boot, please refer to your machine or motherboard's support materials or website.

Type or copy and paste the following commands in a terminal:

$ sudo apt-get install git
$ git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
$ cd backport-iwlwifi
$ make defconfig-iwlwifi-public
$ sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
$ make -j4
$ sudo make install

Then restart. After the kernel update, you will need to run these commands in terminal:

$ cd backport-iwlwifi
$ make clean
$ make defconfig-iwlwifi-public
$ make -j4
$ sudo make install

Once this is done, you should be able to connect to your wireless access point.

Credit goes to Jeremy31 on StackExchange for the guide - https://askubuntu.com/questions/1016903/alienware-17-r4-ubuntu-16-04-wifi-driver

Have a question about your Killer product that isn't answered in our Knowledge Base?  Contact Us.